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WHAT IS TOOLBAG?

Marmoset Toolbag™ is a full-featured, real-time material editor and presentation tool bundled in
a small package. Our goal is to provide each and every 3d artist an efficient and effective
workflow to bring AAA presentation quality to their custom models, texture sets, and animations
in a real-time environment -- without the hassle and time-sink of expansive shader network
setup and lengthy compile times.

PRIMARY FEATURE LiIST

¢ HDR image-based environment lighting

¢ Dynamic light creation and editing

e Sky Tool — create custom image-based lighting environments

e Smart scene-matched shadow projections

e Screen Space Ambient Occlusion (SSAO)

e Circle of confusion / Bokeh depth of field effect

o Direct3D 11 Tesselation/Displacement mapping

e Supersampling Anti-Aliasing (SSAA) screenshot output

e HDR screenshot output

e Auto-turntable options w/ video output

e 6 material blending modes

e 7 shader presets

e 14 viewport rendering modes

e Tangent-space & World-Space normal map support

e Alpha-to-coverage transparency

e Editable Cinematic post-effect system -- including brightness/contrast, saturation,
sharpen, bloom, vignette, and more...

e Drag-and-drop GUI support for textures, meshes, materials, and more

e Normal map invert/swizzle options

Toolbag™ is very much an evolving product, and we’d love for all of its users to be part of the
process. Feel free to send your ideas for new features, or other fun stuff, to:
toolbag@8monkeylabs.com
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INSTALLATION

Before installation, it is highly recommended you update the video drivers for your graphics
device. For driver downloads, visit:

e nVIDIA - http://www.nvidia.com/drivers

e ATI - http://ati.amd.com/support/driver. HT ML

When ready to install Toolbag, click to run Marmoset_Toolbag_install.exe. Follow the
instructions on the pop-up windows as you navigate through the setup wizard.

By default, it will install to: C:\Program Files\MarmosetToolbag.

TECHNICAL SUPPORT

Please direct all technical inquiries and bug reports to: toolbag@8monkeylabs.com

MINIMUM SYSTEM REQUIREMENTS

e Microsoft® Windows® XP (Service Pack 2)

e 2.0GhzCPU

e 1GBRAM

e 250 MB available hard drive space

e nVIDIA® GeForce™ 6800 / ATl Radeon® x1600 w/ 128 MB of video memaory

RECOMMENDED SYSTEM REQUIREMENTS

e Windows® Vista/Windows® 7

e 2.0+ Ghz dual-core CPU

e 2.0GBRAM

e 250 MB available hard drive space

e nVIDIA® GeForce™ 400 series / ATI Radeon® HD 5000 series
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VERSION HISTORY

Version 1.0

o Initial Release

Version 1.01

e Features Added:

O O O O O

Double-layered Phong material

FBX file loader

“‘RLE compressed” .tga files are now supported
Sky light brightness slider

Double-sided lighting

e Bug Fixes:

O O O O

Light editing controls now work with the field of view setting

Improved z-projection settings, dramatically reduces z-fighting in some meshes
Refraction material fixes, wireframe display and texture editing

Better default material (matte gray instead of pink wireframe)

Version 1.02
e Features Added:

O O O O O O O O O O o0 O

Sky Tool — generate your own lighting environments

Skin Shader 2.0 — new controls for skin tone, translucency, and masking

Built-in Video Capture system

Cyan/Red & Amber/Blue 3D stereo rendering

Chromatic Aberration post effect added

Texture preview window added to each texture slot — w/ mipmap level previewing
Light gels — texture projection from point and spot lights

‘Duplicate Light’ button for dynamic lights

Mesh changes can now auto-update like textures

Default Scene file — custom scene setups can now be saved as Toolbag’s default
Floor object added. Floor settings are found on the ‘View’ menu tab.

Mesh triangle count display

e Bug Fixes:

0O O O 0O o 0O O O O

Sky brightness and rotation now save to scene files

Normal map swizzle and flip now save to scene files

“Peter Pan” artifact resolved with a “Front Faces Cast Shadows” set as default
Specular sharpness now work properly with Fresnel settings

Improved default light placement

Resolved the “flickering” issue with wireframe overlay

Fixed the color discrepancy between viewport and screenshots

Cosmetic GUI changes to enhance button legibility.

The corrective lens on the Human Scale Reference now renders properly.
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Version 1.03
e Features Added:

Direct3d 11 Tessellation/Displacement mapping

“Super” screen shot mode for very high resolutions and supersampling
Improved anisotropy shader with a uniform aniso direction slider
Contextual help, a.k.a. Tool Tips

Orthogonal auto-snap on camera rotation (alt+shift+LMB)

Custom camera bookmarks/multiple camera support

Toolbag trial period extended to 30 days

Keyboard shortcut for cycling through menu tabs (tab)

Shortcut button under the ‘File’ menu tab to load User's Manual
Watermark toggle (“Rendered with Marmoset Toolbag”) for full licensees

O O O OO0 OO0 O O O

e Bug Fixes:

Alpha-to-coverage now supported in screenshot output

Resolved gamma issues with screenshot output with latest ATl & NVIDIA drivers
Dynamic lights now support translucent materials

Marmoset mesh format (.mesh) now auto-updates correctly

Bloom settings now properly save into scene files (.tbag)

Depth-of-Field settings now properly save into scene files (.tbag)

Wireframe & Outline modes now update correctly with animated models
Resolved 3d Stereo mode disabling when Toolbag is minimized to the taskbar
Fixed ‘Blend Mode’ box not refreshing properly when switching material selection
Currently selected animation (.anim) now saves in scene files (.tbag)

Fixed Normal map swizzle settings not working with dynamic lights

Fixed a few “Unsaved changes” checks that occur when closing files

0O 0 o o O o o o o 0 o o

SUPPORTED FILE TYPES

3D MESHES

e Alias|Wavefront Object (.obj)
e Autodesk FBX (.fbx)

o Mesh data only; does not currently support animation data.
e Marmoset Mesh Format (.mesh)

o This is 8monkey’s proprietary mesh format for the Marmoset Engine. This
format can contain vertex positions, normals, tangents, bitangents, colors,
vertex weights, and a full complement of texture coordinates.
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IMAGES

e Truevision TGA (.tga)
e DirectDraw Surface (.dds)
e Photoshop Document (.psd)
o Supports 8, 16, & 32-bits/Channel, Grayscale and RGB Color modes
o Portable Float Map (.pfm)

o For more information on the PFM format, visit:
http://gl.ict.usc.edu/HDRShop/PEM/PEM Image File Format.html

VIDEO

e Video capture feature will export a movie file in the uncompressed .avi format.

KEYBOARD SHORTCUTS

Hide/Show Palettes space bar
Camera Tumble alt + LMB
Camera Tumble Snap shift+alt+LMB
Camera Zoom alt + RMB
Camera Track alt + MMB
Rotate Model ctrl + LMB
Translate Model ctrl + MMB
Rotate Sky shift + LMB
Human Scale Reference ctrl +/
Cycle Menu Tabs tab
Reset/Re-center Camera E
Start/Stop Turntables T
Start/Stop Video Capture F9

Take Screenshot F12
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BASIC WORKFLOW

EXPORT YOUR MODEL

As mentioned above, Toolbag has support for .obj’s, .fox and .mesh. Export your model from
your 3d modeling application of choice.

**If using Maya, and wanting to export using Marmoset’s proprietary mesh format, you must
first install the StoogeExport plugin and .mel script.

Installing StoogeExport

All necessary scripts & plug-ins are located in MarmosetToolbag\exporter\.

With Maya closed:

1. Copy the appropriate .mll for your version of Maya into your Maya installed
directory, into bin\plug-ins\.

a. Sample file path: C:\Program Files\Autodesk\Maya2010\bin\plug-ins\

2. Copy the stooge.mel script file into any suitable script folder, ideally My
Documents\mayal\scripts\.

3. Open Maya. Go to the plugin window (Window->Setting/Preferences->Plug-in
Manager). Search for the "stoogeExport" plugin, and check both the "Loaded" and
"Auto-Load" checkboxes.

Toolbag presently offers StoogeExport plug-ins for the following versions of Maya:

e Autodesk Maya 7

e Autodesk Maya 8

e Autodesk Maya 2008

o Autodesk Maya 2009 (32 & 64 bit)
e Autodesk Maya 2010 (32 & 64 bit)
e Autodesk Maya 2011 (32 & 64 bit)

Running StoogeExport

Once the appropriate .mll and .mel script are installed, you initiate the export process by
simply typing stooge into the MEL command line and hit ‘Enter’ on your keyboard to run
the script. You will then be presented with an options dialog. Hit the ‘export’ button when
you are ready to go.

Export Options:

o \Write Tangents/Bi-Tangents - On by default. Anytime you’re exporting a mesh,
make sure this is checked.

© 2011 8monkey Labs Inc.
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o Write Rig File - Make sure this is checked anytime you’re exporting a mesh for the
first time. Subsequent exports of the same mesh do not require a new rig file, as
long as the mesh chunks in Maya have not changed names.

e Write Bone Weights & Skeleton - Check this only if the mesh you are exporting
has vertex weights/animation data.

Marmoset Engine’s animation system currently supports a maximum of 50 joint
influences per mesh chunk. If you have more than 50 bones influencing any one
mesh chunk this will cause a crash when loading animations in Toolbag. If you do
run into this issue, a few recommended ways to lower the joint influence count
would be:

o Append “DONTEXPORT” to the name of any dummy joints that are not
directly influencing vertices, i.e. fingertip joints, toetip joints, secondary 1K
rigs, etc... This name change will tell StoogeExport to omit these joint
influences from your .mesh

o Split up your mesh into multiple chunks. It is certainly more destructive and
time-consuming, but may be necessary to get your number of joint
influences under 50 per mesh chunk for final showcasing in Toolbag. For
example, split a full body mesh into “lower body” and “torso”.

e Export only Animation - Check this box if you are ready to export individual .anim
files. If checked, all other options in the StoogeExport window will be ignored. To
determine what frames are exported, set the min/max of your playback range slider
in Maya to the first and last frames of the desired animation cycle/sequence.

Proprietary File Types

.mesh - A mesh file that may contain vertex positions, normals, tangents, bitangents,
colors, and a full complement of texture coordinates. This file is almost always paired with
a .rig file (see below).

.rig - A user-editable text file that contains material bindings. Edit this file in order to bind a
material (.mat) to a mesh. The .rig contains a listing of mesh chunks from the exported
maya scene, along with an assignment of what material file each mesh chunk will use.
Each material assignment will default to "placeholdermaterial.

.skel - A skeleton file that contains the bone structure for an animated mesh. This file gets
exported simultaneously with a .mesh file, and the two should generally be considered to be
joined at the hip (pun intended).

.anim - An animation sequence. This is exported independently of the .mesh, .rig, and
.skel so that a single animated mesh can have several animations.

LoAD YOUR MESH

© 2011 8monkey Labs Inc.
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Run ‘toolbag.exe’. Once opened, under the ‘File’ menu tab, click the “Open Mesh” button,
navigate through the standard Windows dialog prompts, and you’ll be ready to rock.

You may also choose to drag-and-drop your mesh into the Toolbag viewport if that kind of
savvy workflow is to your liking.

CREATE MATERIALS

1. Selecting the ‘Mat’ tab will open the ‘Chunks/Materials’ GUI palette on the right side of
your window. You will notice all available mesh chunks listed up top, with a “Materials”
box where your materials assigned to your mesh will be listed. Located near the bottom
of the ‘Chunks/Materials’ palette, click "New Mat". Follow the standard Windows dialog
to choose a file name and save location for your new material (.mat).

2. To apply your newly created material, select the mesh chunk you wish to apply it to
from the "Chunks" list, select the material from the "Material" list, and click the button
that reads "Apply Selected Material".

3. Now that you have a new material, you need to set up its attributes. With a material
selected, the left palette will now show all of your available shader options to use with
your chosen material.

EDIT MATERIALS

1. Select which Shader Channel Model to use.

PhongEnvironment

This is the standard shader, it will be used for most materials. It has available slots for:
= Diffuse map
— Transparency stored in alpha channel
= Normal map
— Parallax stored in alpha channel
= Specular map
— Gloss map stored in alpha channel
— Gloss map treated as a multiplier on global Spec sharpness slider
= Detail Normal map
— Load a uniformly-tiling tangent-space Normal map
= Occlusion map
— Use for baked ambient light maps on a 2nd UV channel

= Emissive map (aka “Glow map”)

© 2011 8monkey Labs Inc.
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= Translucency map

— Good for simulating transmission of light through thin surfaces: tree
leaves, rice paper, etc...

— RGB channel determines diffused light transmission through the mesh,
with the alpha channel used to mask this effect.
PhongDoubleLayerEnvironment
This is the standard shader with additional support for 2 layers of Diffuse, Normal, and
Specular maps. Uses the texture loaded in the ‘Layer’ slot to blend between maps.
PhongSimpleEnvironment

A basic shader, with input for Diffuse map and Occlusion map only.

AnisotropicEnvironment

An identical shader to PhongEnvironment, with an additional slider for the direction of
anisotropy strands, and a texture channel for defining this direction per-pixel (texture is
optional). This shader is ideal for hair and brushed metal. Strand direction is always
defined in tangent-space and is directly tied to the orientation of the mesh's texture
coordinates.

= Direction Map

— RGB channel contains tangent-space unit vectors defining the flow of
anisotropy strands along the surface -- much like a normal map but the
direction vectors all lie in the XY-plane.

— If present, this texture will override the Anisotropy Direction slider.
= Show Anisotropy Direction

— Toggles visualizing the anisotropy strands on the surface of the mesh --
mainly intended for debugging.

= Anisotropy Direction

— Angle in degrees defining the anisotropy strand direction uniformly across
the entire mesh, in tangent-space.

— This value will be ignored if a direction map is present.

ComplexRefraction

This shader model is ideal for simulating glass and/or plastic materials that may
necessitate various levels of transparency and surface detail.

FlatEnvironment

This is similar to PhongSimpleEnvironment, but is full-bright with no lighting.

© 2011 8monkey Labs Inc.
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SkinEnvironment

This is the skin shader. Its options are identical to PhongEnvironment, with an additional
channel for Skin tone/Skin mask, and include settings to control dermis and subdermis
color, as well as the light scattering factor.

= Skin Tone/Mask map
— RGB channel is used as skin tone
— Alpha channel is the mask. The mask will differentiate between skin-
shaded and phong-shaded surfaces on a mesh (i.e. skin -vs- clothing)
— The dermis/subdermis color pickers will be multiplied against the Skin
Tone map if one is loaded.

= Scattering
— Blends between Phong (0.0) and fully-scattered skin lighting (1.0).

= Subdermis Depth
— Controls the influence of subdermis color over the dermis color in the
light gradient.

= Scatter Smoothing
— Smooths the Normal map for the light scattering term only. Only
applicable to tangent-space Normal maps.

2. After you've selected your Shader Channel Model, load your texture maps into their
corresponding channels.

e You may do so through the standard Windows dialog by clicking the button for
each slot, or simply drag-and-drop the texture map from Windows Explorer onto
the appropriate slot.

3. Save your new materials! Located at the bottom of the ‘Chunks/Materials’ palette on
the right, click “Save Mesh & Materials” to save your mesh chunk material assignments
along with all your material changes.

SET LIGHTING & POST EFFECTS

1. Select the ‘Sky’ tab on the GUI, and then choose your base lighting environment from
the “Env Lighting Presets” dropdown list.

e The main lighting system in Toolbag is image-based lighting, based on HDR
cube maps. This lighting comes 100% from pre-set CubeMaps; a set of 10
different environment presets are included in this release.

2. You may also create additional dynamic lights in the scene. These are excellent to use
as fill lights, spotlights, or even use the dynamic lights as key lights if you chose the
“Black” environment light preset.

© 2011 8monkey Labs Inc.
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o Click “Add Light”, and it will appear in your list. With a light selected, set it's
parameters using the options lower on the palette. Set the color, intensity,
radius, and even animate it.

e Translate/Rotate each light in your scene by using the in-world widget, or the
slider bars at the bottom of the ‘Light’ tab.

e By default, all dynamic lights created are ‘omni’ lights. Check the “Spotlight”
checkbox to make it a ‘point’ light. Point lights support cast shadows, while
Omni lights do not.

3. After you are happy with your lighting setup, check out the ‘Render’ tab. Here you will
find a wide variety of render view options, advanced rendering features (such as SSAO
& DOF), as well as full palette of sliders to edit, save, and load your own cinematic post
effects.

Use all the features of the ‘Render’ tab to stylize your scene to your heart’s content!

SHOWCASE YOUR WORK

Now that you’ve edited your materials, customized your lighting, set your post effects, it's time
to showcase your hard work. You have two basic options:
Take Screenshots
Under the ‘File’ tab, you'll find a ‘Screenshots’ section.
1. Click “Set Output” and follow the Windows dialog to set your export destination.
2. Select your desired resolution from the ‘Enlargement’ dropdown list.
o ‘None’ will export at the current resolution of Toolbag’s application window.

o ‘2%, ‘3X, etc. will enlarge the horizontal resolution of your exported
screenshot by the selected factor. The vertical resolution will be
automatically determined by your monitor’s aspect ratio.

3. Choose your “Supersampling” factor. The higher the number, the smoother/crisper
the edges will be and less aliasing you'll see.

4. Click “Take Shot” (or hit F12) to capture screenshot.

o The screenshot will be written as a 32-bit TGA; the background of the scene
written to the alpha channel to make for easy compositing/layering after
export.

e “Include UI” will do just that; include the Toolbag user interface in the
screenshot.

e “HDR” checkbox will export the screenshot as a high-dynamic range .pfm.
This option is excellent if you wish to have multiple exposures of your scene,
or simply “If you’re into this sort of thing.” It has a few limitations:

© 2011 8monkey Labs Inc.
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= This option will not contain an alpha channel.

= This option will not be gamma-corrected. You'll need to manually
adjust the curves in Photoshop to gamma-correct the exported PFM,
and match the gamma/color seen in Toolbag’s viewport.

= A .pfm will have a considerably larger file size than an LDR, 32-bit
TGA. Typically, 3x the size.

¢ “Include Toolbag logo” will re-enable the Marmoset Toolbag watermark on
your exported images and video — to show the world how you get your pretty
pictures, of course. **This option is only available for full licensees**
Capture Turntable Videos

Under the ‘View’ tab, you'll find a ‘Turntable’ section of options. This contains 3 sliders to
independently control the world-space rotation of your Mesh, Environment Lighting, or
Camera. Use ‘T’ as a shortcut to start/stop turntable rotation.

You can capture/export your viewport turntables using Toolbag’s very own video capture
export tool, or via 3" party software.

Toolbag Video Output (beta)

1. Set your desired rotation speed for each component by adjusting the turntable
sliders.

2. From the ‘Video’ section of the ‘File’ menu tab, choose your output destination.

3. Specify your desired ‘Video Size’ output (based on your Toolbag window’s current
resolution)

4. Enable ‘Auto-Stop’ if desired. This feature will stop the video capture process after
one complete revolution of your selected turntable style is reached. You can also
start/stop video capture using the shortcut, ‘F9’. If ‘Auto-stop’ is disabled, you will
need to manually stop the video capture process.

3" Party Software

1. Set your desired rotation speed for each component by adjusting the slider or using
text entry.

2. Use a 3" party application, such as FRAPS (or something similar), to capture the
turntable as a video.

¢ To download FRAPS, visit: http://www.fraps.com/download.php

e If you're interested in a more robust video-capture hardware setup of your
own, check out a few of Blackmagic Design’s products:
http://www.blackmagic-design.com/products/
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o ***\We do not offer support, or guarantee the effectiveness of either of the
video capture solutions above; they are simply systems that have worked well
for us in the past.

3. Toreset your Mesh, Camera, or Environment Lighting to their original
positions/rotations, use the ‘Reset’ buttons located below the turntable sliders.

SAVE YOUR SCENE

After all this work, you more than likely would love to be able to come back and edit your
render settings, and take more screenshots at a later time. You may do so by saving out a
custom Toolbag Scene File (.tbag).

Under the ‘File’ tab, you'll find a ‘Scene’ section of buttons. Click “Save Scene As” and pick a
desired location. If you are returning to Toolbag, and want to load a previous scene, simply
click “Open Scene”, navigate to your saved .tbag file, and click ‘Load’.

Toolbag Scene Files, for all intents and purposes, will save everything you may have possibly
edited during a session of using Toolbag.

© 2011 8monkey Labs Inc.
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SKY TOOL

Marmoset Toolbag now includes a pipeline providing the ability to generate your own, custom
image-based lighting environments. To access the Sky Tool, click the “Sky Tool” button found
under the ‘Light’ menu tab.

INPUT

Open Image

Load your base environment lighting image here. The sky tool allows input of the following
formats:

e Horizontal Cross cube map (4:3)

e Vertical Cross cube map (3:4)

e Latitude/Longitude Panorama

e Vertical column (1:6)
To achieve a maximum Specular and lighting range in your custom lighting environment, it
is highly recommended you use HDR image input (.dds or .pfm), although .tga and .psd are
also accepted.
Open Shadow Image

You'll notice your base environment lighting image is used in this channel by default. If you
wish to generate an ambient lighting environment (no global shadows), leave this as-is and
move onto the ‘Preview’ section.

If you do wish to have global shadows in your lighting environment, load your custom
shadow environment image here.

o What’s the difference between the base lighting image and the shadow
image?

Toolbag will determine the shadow direction by picking the brightest pixel in the base
environment lighting image (for example, a pixel from the sun). This direction is used
for casting sky shadows. The shadow image is typically a copy of the lighting image
with the “light source” (i.e. the brightest pixel) edited out. Here is a sample:

BASE LIGHTING IMAGE SHADOW IMAGE
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PREVIEW

The two rows of spheres in your Sky Tool viewport help you visualize how various levels of
diffuse color and specular intensity will appear, before you follow through with the generation
of your custom Sky lighting environment.

The utilities in this menu section allow you to sample various levels of Specular sharpness,
preview shadow lighting, and test for proper shadow direction.

e My shadow direction is incorrect. What did | do wrong?

If your map does not have a clear "brightest" section, then it is a poor candidate for
shadows, and Toolbag will likely not be able to pick a very good shadow direction.
Note however that you may edit the shadow direction by hand by opening the .env
file in a text editor after your sky is exported.

OUTPUT

Adjust the global brightness of your lighting environment, ‘Export Sky’ to your desired location
(...\Marmoset Toolbag\base\sky\ is recommended), wait 1-2 minutes for processing, and
you’re ready to rock.

To use your newly-generated custom lighting environment in Toolbag, simply load it by using
the ‘Open Sky’ button under Toolbag’s ‘Light’ menu tab.
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TOOLBAG PROTIPS

WELDED UV’s

Make sure the mesh(es) you're importing to Toolbag do not have incorrectly welded UVs. This
is often the result when two nearby vertices’ corresponding UVs are welded together, thus
causing their bi-tangent/tangent data to get corrupted.

You will notice this problem in Toolbag if the polygons adjacent to these welded UVs appear to
be unlit. A ‘weld tolerance’ set too high in your modeling app is often the culprit here.

MESH CHUNKS

To assign multiple textures/materials to the same mesh, your mesh must have multiple mesh
chunks. In Max/Maya/Modo this means you want to have your meshes separated into different
objects for each material that you plan to use.

For example, if you want a section of a character mesh to use the Skin Shader for the head,
and standard Phong Shader for the torso, split the face & torso sections of the character mesh
into separate objects (no adjoining vertices) before saving your OBJ (or exporting your .mesh).

SKIN SHADER

#1: Subtlety - Do not crank the sliders to the max. Human skin is fairly opaque so the best
rendering results tend to lie in the mid ranges of Scattering and Subdermis Depth.

#2: Let Lighting Do the Work - Keep Diffuse and Skin Tone maps free of surface
deformations like wrinkles and "airbrushed abs”. Details like wrinkles define the shape of your
model and should ideally come from your Normal map, allowing the skin shader to light them
properly and render them with the same color ramp and subsurface scattering as the rest of
the skin.

#3: Keep It Simple - Much of the redness and blush of human skin comes from light
scattering off the flesh underneath the surface. For best results, it helps to think of the Diffuse
map as surface detail only (i.e. dirt, grime, tattoos, and hair), while leaving the tonal variations
of the skin (i.e. blush, veins, blemishes, etc...) in the RGB channel of the Skin Tone map.

It is possible to get good skin results without having ANY color detail in the Diffuse or Skin
Tone map. The RGB values of the Skin Tone texture are entirely optional, leaving skin tone to
be controlled entirely by the Dermis/Subdermis colors. In the end, the simpler, the better.

#5: Black & White Skin Mask - The Skin Mask (alpha channel of the Skin Tone map) is
intended to differentiate between skin-shaded and phong-shaded surfaces on a mesh (i.e. skin
versus clothing). It is possible to put shades of grey in the mask to define some surfaces as
more "skin-like" than others but in practice this rarely looks good. Usually the model ends up
looking as if caked in makeup.
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ANISOTROPY SHADER

#1: Proper Use — The anisotropy shader can be used to great effect when rendering sleek,
shiny hair and polished/brushed metal surfaces. The shader's overall effect is to stretch out the
specular highlight (and, to a lesser extent, the diffuse highlight) across the fine strands of hair
or scratches on the anisotropic surface. This effect is much more pronounced when the scene
is lit by dynamic lights (point lights and spot lights) due to Marmoset Engine’s dynamic lighting
system being separate from, and in some key ways simpler, than the image-based
environment lighting system. Consider using a dynamic light as the clear source of specular
highlights on any anisotropic surfaces.

#2: Controlling Anisotropy Direction — The flow of anisotropy strands along the mesh
surface can be defined by a texture or a single direction vector. This direction of flow is always
interpreted as being in tangent-space much like a tangent-space normal is in a normal map.
Normals point straight out of the mesh in the Z-direction whereas anisotropy strands flow
along its surface in the XY-plane.

#3: Hide Yo’ Seams - Toolbag's tangent-space is defined at every polygon by the orientation
of its texture coordinates. If two polygons share an edge and contiguous texture coordinates
then the anisotropy strands will flow smoothly across that edge. If there is a texture seam
between the two polygons, a seam in the flow of the strands may appear and the specular
highlight may break in unexpected places. Great care may be needed to hide these seams
when dealing with more complex, closed meshes (such as sharks and horses) because a
single contiguous UV mapping for them is often not possible. Note that these seams may not
appear with a standard Phong material because the normal map was baked with the
orientation of tangent-space in mind. But because no such baking tools exist for direction
maps, anisotropy is at the mercy of your model's UV layout.
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LICENSE KEY PROBLEMS

HARDWARE CHANGES

If the hardware components in your machine change too much, your Marmoset Toolbag
license key may be invalidated. In the event this happens, feel free to contact us at:
toolbag@8monkeylabs.com

OPERATING SYSTEM CHANGES

If you have reformatted your hard drive, or upgraded your OS to a new version, your hardware
fingerprint will most likely change, and your Marmoset Toolbag license key may be invalidated.

In this event, please ensure you’ve completed all necessary OS auto-updates, retrieve your
new fingerprint from Toolbag’s ‘Enter Key’ window, and send your fingerprint and invoice ID to
us at: toolbag@8monkeylabs.com

We'll have your license back up and running in no time.
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TRANSFERING YOUR NODE-LOCKED LICENSE

Marmoset Toolbag is intended to work on only one (1) computer at a time, and your Toolbag
license key is locked to the hardware of that computer. However, you are free to transfer your
license to a different computer as many times as you wish. This process uses your installed
copy of Marmoset Toolbag to generate a new license key for the new computer and invalidate
the old key.

TRANSFER TO A NEW COMPUTER

You will need to retrieve the new computer's hardware fingerprint and use it to generate a new
license key.

1.

Install and run the free trial version of Marmoset Toolbag on your new computer that
you wish to transfer your license to.

When presented with the Trial Reminder splash page, click the ‘Enter Key’ button.

Write down the Hardware Fingerprint presented to you in the dialog that pops up. This
fingerprint identifies your new computer and will be used to generate a new license
key. The fingerprint will be of the form XXXX-XXXX. Keep this dialog open as we will
return to it soon.

On the old computer, run LicenseTransfer.bat out of the MarmosetToolbag\ directory.
You will first be asked to confirm that you want to invalidate your old key and generate
a new one. Click "Yes."

You will then be prompted for the Hardware Fingerprint (a.k.a. the "Hardware-Locking
Code"). Enter the Hardware Fingerprint written down from Step 3 and click Ok. If
successful, you will be presented with your name and new license key.

WRITE THIS NAME AND LICENSE KEY DOWN! If you accidentally click through
without saving this information, you will have to contact technical support.

Go back to the computer you wish to transfer your license to and enter the name and
license key, exactly as they appear, into the "Enter Key" window. It should be left open
from Step 3, otherwise start the free trial version of Toolbag up again and click the
"Enter Key" button.

Congratulations, you have transferred your full license of Marmoset Toolbag!
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NETWORK (SITE) LICENSES

Networked licenses of Marmaoset Toolbag allow as many copies of Toolbag as were
purchased to run on any machines on a Local Area Network (LAN). This is done through a
client/server model in which one machine on the LAN runs the Marmoset Toolbag license
server. All other machines on the LAN connect to that server and ask permission to run. The
number of purchased copies determines how many copies of Toolbag can be operating
simultaneously on one LAN.

REGISTER YOUR LICENSE SERVER

To register the networked license key you purchased from the 8monkey Store:
1. run "Register License Server.bat" batch file included in the installation
OR
2. run Toolbag.exe with the command-line argument "toolbag.exe SERVER REGISTER".

IMPORTANT: Network license keys of Marmoset Toolbag do NOT work in the standard
"Enter Key" dialog of the Toolbag trial version. You MUST use the batch file or command-line
argument listed above.

RUN YOUR LICENSE SERVER

To start the license server:
1. run the "Start License Server.bat" batch file included in the installation.
OR

2. run Toolbag.exe with the command-line argument "toolbag.exe SERVER".

Once the server is up and running, any other copy of Toolbag on the network will first look for
a license server, failing to find one will look for a local, single node-locked license, and failing
that will start up in Trial Mode.

TOOLBAG CAN'T FIND MY LICENSE SERVER!

Running Windows Firewall tends to block the UDP port client that Toolbag.exe uses to find the
license server. To fix this you will need to add a new inbound UDP port rule (or UDP port
exception in windows XP) to your Windows Firewall settings of the computer that will be
running the license server.

Windows Vista/7 instructions
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Launch the Toolbag license server and make note of the UDP port number that
appears in the server message window. It should be on the line saying something like
"Locator started on UDP Port XXXXX".

2. Go to Control Panel -> System and Security -> Windows Firewall -> Advanced Settings
3. Right-click on the Inbound Rules category and add a New Rule.

4. Inthe New Inbound Rule Wizard, create a Port Rule that applies to UDP and set the
Specific Local Port to be XXXXX from step 1. You will want to allow this connection
even if its unsecure. The name and applicable domains for this new rule are up to you.

5. Click Finish and clients should now be able to find your Toolbag license server.

Windows XP instructions

1. Launch the Toolbag license server and make note of the UDP port number that
appears in the server message window. It should be on the line saying something like
"Locator started on UDP Port XXXXX".

2. Go to Control Panel -> Security Center -> Windows Firewall
3. Select the Exceptions tab and click the button labeled "Add Port".

4. When prompted, select the UDP radio button, enter the full path plus file name of your
Toolbag install (ex: "C:\program files\MarmosetToolbag\toolbag.exe"), and the UDP
port XXXXX from step 1.

5. Click OK and clients should now be able to find your Toolbag license server.
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